“Login is not currently available for DataSite One. All Teams are currently working to restore full functionality.”
Incident Report for Datasite
Resolved
This incident has been resolved.
Posted Oct 06, 2019 - 12:47 CDT
Monitoring
Login page has been restored. Teams are monitoring now.
Posted Oct 06, 2019 - 12:15 CDT
Investigating
We are currently working through this issue.
Posted Oct 06, 2019 - 11:53 CDT
This incident affected: EMEA & APAC (Datasite Diligence) and North America (Datasite Diligence).