Some Datasite users are experiencing connectivity issues due to a common IT provider experiencing widespread connectivity issues. We are monitoring the situation.
Incident Report for Datasite
Resolved
Services have returned to normal.
Posted Aug 30, 2020 - 10:57 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2020 - 08:47 CDT
This incident affected: EMEA & APAC (Datasite Diligence, Datasite Outreach) and North America (Datasite Diligence, Datasite Outreach).