Users may be experiencing issues with logging in and overall platform performance

Incident Report for Datasite

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 15:44 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2026 - 15:02 CST

Update

We are continuing to investigate this issue.
Posted Feb 13, 2026 - 14:01 CST

Investigating

We are continuing to investigate this issue.
Posted Feb 13, 2026 - 14:00 CST

Identified

Technical teams are continuing to troubleshoot the Datasite platform issues. We will provide an update once new information is available.
Posted Feb 13, 2026 - 13:59 CST

Investigating

We are continuing recovery efforts. Service remains unavailable, and we will provide further updates as progress is made.
Posted Feb 13, 2026 - 11:57 CST
This incident affected: North America (Datasite Diligence), EMEA (Datasite Diligence), and APAC (Datasite Diligence).