Due to a Microsoft incident, some SSO users may be unable to log in to Datasite

Incident Report for Datasite

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 12:22 CDT

Monitoring

Microsoft has indicated they have resolved the issue on their side.
Posted Oct 29, 2025 - 12:21 CDT

Identified

Due to a Microsoft incident, some SSO users may be unable to log in to Datasite. If you are affected, please contact your corporate IT group for updates from Microsoft.
Posted Oct 29, 2025 - 11:44 CDT