Datasite Projects are not loading in the US. Projects in EU and AU are not impacted
Incident Report for Datasite
Resolved
This incident has been resolved.
Posted Jul 27, 2022 - 17:17 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 27, 2022 - 17:02 CDT
Update
We are working with our vendors to solve this issue, and will update as soon as functionality is restored or an ETA is available
Posted Jul 27, 2022 - 16:43 CDT
Identified
The issue has been identified and a fix is currently being implemented
Posted Jul 27, 2022 - 16:22 CDT
This incident affected: North America (Datasite Diligence, Datasite Outreach).