Datasite Service Team Unable to Receive Emails
Incident Report for
Datasite
Resolved
This incident has been resolved.
Posted
May
11
,
2021
-
20:13
CDT
Identified
Due to a widespread Salesforce outage, we are unable to receive emails at
service@datasite.com
. Please contact Datasite support using your local phone numbers as found here:
https://www.datasite.com/us/en/contact/support.html
Posted
May
11
,
2021
-
17:22
CDT
×
Subscribe to Incident
Subscribe to updates for
Datasite Service Team Unable to Receive Emails
via . You'll receive .